Symptom:
When you read a file from local disk, you may receive the following error message returned by our SDK:
The file type is not supported
Causes:
The problem may be caused by one of the followings.
- The loaded file type may not be PNG, JPG, BMP, GIF, TIF or PDF on Windows OS.
- Reading barcode from PDF files on Mac OS X.
- Missing DynamicPdf.dll or DynamicPdfx64.dll in your application.
Resolutions:
Please find the corresponding solution from the followings.
- Convert the file type to PNG, JPG, BMP, GIF, TIF or PDF on Windows OS
- The feature of reading barcode from PDF files on Mac OS X will be supported soon.
- Copy DynamicPdf.dll and DynamicPdfx64.dll from installation directory of Dynamsoft Barcode Reader, and paste them into the same folder as DynamsoftBarcodeReaderx86.dll or DynamsoftBarcodeReaderx64.dll.
Typically they could be found at:
C:\Program Files (x86)\Dynamsoft\Barcode Reader {Version Number}\Components\C_C++\Redist\