Symptom:
When you generate the LPK file or run a TWAIN application, you may receive the following error message:
Cause:
The problem may occur when the license is invalid.
Resolution:
This problem may occur in the following conditions:
The error occurs when generating a LPK file.
The error occurs when running a web application.
The error occurs when developing a desktop application.
The error occurs when generating a LPK file.
The problem occurs when the license in Licensing Tool is invalid. Licensing Tool can be found at "start -> All Programs -> Dynamic Web TWAIN (version number) -> Licensing Tool". Please click here for more information about how to change the license in Licensing Tool.
After you change the license in Licensing Tool, please run Lpk_tool.exe again to generate the LPK file.
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The error occurs when running a web application.
1. Make sure the LPK file exists on your web server and the code used to set the path of the LPK file is correct.
In the scan page, there should be an <object> tag for the License Manager object before any other <object> tags.
Code:
<object classid = "clsid:5220cb21-c88d-11cf-b347-00aa00a28331" VIEWASTEXT>
<param name="LPKPath" value="DynamicWebTwain.lpk" />
</object>
The value parameter of the <param> tag indicates the path of the LPK file on your web server. For example, if value="DynamicWebTwain.lpk", the DynamicWebTwain.lpk file should be placed in the same directory with the scan page on your web server.
Please pay more attention to the value of this parameter if you are using a case sensitive server like Tomcat. If you are using a Friendly URL, please place the LPK file at the root directory on your web server and then modify the value of the value parameter to value="/DynamicWebTwain.lpk".
Please click here for more information about how to install Microsoft Licensed Class Manager 1.0 on your machine.
3. Make sure the Time/Date setting of the client machine is correct.
Every trial LPK file has a 30-day period for evaluation. When the Time/Date of the client machine is out of the 30-day period, the LPK file will be invalid.
4. Make sure your LPK file is generated correctly. Please click here to check the steps on how to create a LPK file. If you are not sure whether your LPK file is invalid, you can send it to TWAINsupport@dynamsoft.com and we will check it for you.
If you have done the above 4 steps and the problem still exists, please try deleting browsing history at "Tools -> Delete Browsing History" or removing "DynamicWebTwain Class" which can be found at
"C:\WINDOWS\Downloaded Program Files" and then refresh the web page.
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The error occurs when developing a desktop application.
Please make sure the license in Licensing Tool is available. Licensing Tool can be found at "start -> All Programs -> Dynamic Web TWAIN (version number) -> Licensing Tool". Please click here to check the steps on how to change the license in Licensing Tool.
