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Error message: The connection with the server was terminated abnormally

Symptoms:

When you upload images in buffer, you may receive the following error message returned by the ErrorString property:



Cause:

1. The problem may occur when a connection with the server is not available.

2. The size of images you are going to upload goes beyond the maximum transferable data size which is defined by the server.


Resolutions:

1. Please make sure the address of the server is available. To check this, you can ping the address from a client machine.

Note: Both the machine name and the IP address of the server can be used for the HTTP Upload method.

2. Please make sure you specify the correct port. The default port is 80. If you are using other port, please use HTTPPort to specify it in code.

We recommend you get the Port and Server value this way:
strHTTPServer = location.hostname;
WebTWAIN.HTTPPort = location.port==""?80:location.port;

3. Please reset the maximum transferable data size:

If you are using ASP:

If you are using IIS 6:
1) Start -> Run , type "cmd"
2) Go to "C:\Inetpub\AdminScripts" by typing: cd C:\Inetpub\AdminScripts
3) To view max request entity allowed:
cscript adsutil.vbs set w3svc/AspMaxRequestEntityAllowed

If you are using IIS 7:
1) Start -> Run , type "InetMgr" to open IIS 7 Manager
2) {Your WebSite}->Feature View->ASP->Limites Properties
3) Set "Maximum Requesting Entity Body Limit" to a bigger value like "1000000"


To set max request entity allowed:
cscript adsutil.vbs set w3svc/AspMaxRequestEntityAllowed 1000000 (You can change the value by yourself.)

If you are using ASP.NET, you can change the value at the following line in the "Web.Config" file.
<httpRuntime maxRequestLength="1000000"/> (You can change the value by yourself.)

If you are using PHP, you can change the value at the following line in the php.ini file:
upload_max_filesize = 2M (You can change the value by yourself.)




Article Details

Last Updated
15th o May, 2012

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Visitor Comments

  1. Comment #1 (Posted by javed )
    i need ti solve error
  2. Comment #2 (Posted by support )
    Does the solution here help? If the problem persists, you can contact us via LiveHelp: http://www.dynamsoft.com/support/livehelp.aspx

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